Github not cloning full repository

I’m working on the reading exercises in parts 17.1 and 17.2.

Background to this issue:
I am a mac user, not sure if that is relevant to the actual issue. When downloading MySQL Workbench, I had to do a system update on my computer in order for Workbench to run properly. I am now running on macOS Big Sur 11.4. Since this update, I’ve had a few issues. Immediately after the update, when I tried to clone the starting branch for the coding events reading exercise 17.1 (enums branch) I tried making a new project from version control in IntelliJ. I received an error stating that I needed Git 2.9+. I tried to update git but was unsuccessful. I am currently running git 2.30.1. After leaving my computer for a few hours, I am no longer getting this error despite nothing having changed. I assumed maybe the issue fixed itself as it was working as expected. However, now the second problem has arisen.

The Issue:
When I made it to 17.2 in the textbook, the video instructed me to look in the “data” package ( coding-events/src/main/java/org.launchcode.codingevents/data), but this package does not exist locally for me. Neither the “data” nor “models” packages or their contents are cloned over. I have attached a screenshot of my IntelliJ file tree.

Attempts to Solve:

  • I have tried deleting all previous versions of the “coding events” repository on my computer, thinking my computer might have been getting confused with multiple folders of the same name.
  • I have tried to clone this repository in multiple different ways such as directly from the command line, a new project from version control in IntelliJ, and GitHub Desktop. All of these give me the same result.
  • I have restarted my computer and all applications.
  • I have tried to update git, but seem to be unsuccessful. Most I can find on google recommends downloading Homebrew, but I have never had nor needed this before.

This seems to be an issue with Git, but I’m not quite sure how to proceed. I can recreate the file tree by copy and pasting it from the repository, but that is only a bandaid and this will obviously be an issue moving forward if not figured out.

Has anyone else had this issue?

Hi! You said that you’re on the enums branch which is listed as the starter branch in 17.1.1.1. When I pull up that branch I don’t see the data or models packages in my file tree either. But when I pull up the branch that contains the completed code for this project - the db-config branch - both the data and models packages appear. If you open up that branch, do you see data and models?

I tried cloning the db-config branch as well. Neither branch contained data or models locally. The only way I was able to get them was by downloading the zip file of db-config instead of cloning the repository. I was able to finish the practice that way. They existed on Github, so I’m just stumped as to why they didn’t clone over.

Since then, I have moved on to Assignment 4 and that cloned over perfectly with no issues.